import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^:\\n]*):(.*?)(?:,Box:([^,\\n]+)(?:,qty:(\\d+))?)?$";
final String string = "Apple: Red\n"
+ "Kiwi: brown,Box:no\n"
+ "Grapes: Black,Box:yes,qty:55\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}