const regex = /([^:\n]*):(.*?)(?:,Box:([^,\n]+)(?:,qty:(\d+))?)?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^:\\n]*):(.*?)(?:,Box:([^,\\n]+)(?:,qty:(\\d+))?)?$', 'g')
const str = `Apple: Red
Kiwi: brown,Box:no
Grapes: Black,Box:yes,qty:55
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}