$re = '/([^:\n]*):(.*?)(?:,Box:([^,\n]+)(?:,qty:(\d+))?)?$/';
$str = 'Apple: Red
Kiwi: brown,Box:no
Grapes: Black,Box:yes,qty:55
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);