#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\h+\|\h+.*\R*"
Local $sString = "adrian-strauch@t-online.de:12xxxxxx | 5" & @CRLF & _
"svenschalke@t-online.de:kikerxxx | 33" & @CRLF & _
"dennis.meinhardt@t-online.de:vxxxxxx | 169" & @CRLF & _
"Fabibau@t-online.de:rofxxxx | 134" & @CRLF & _
"anders.gerd@t-online.de:townxxx | 1" & @CRLF & _
"" & @CRLF & _
"anders.gerd@t-online.de:townxxx | test"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)