package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\h+\|\h+.*\R*`)
var str = `adrian-strauch@t-online.de:12xxxxxx | 5
svenschalke@t-online.de:kikerxxx | 33
dennis.meinhardt@t-online.de:vxxxxxx | 169
Fabibau@t-online.de:rofxxxx | 134
anders.gerd@t-online.de:townxxx | 1
anders.gerd@t-online.de:townxxx | test`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}