// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\h+\|\h+.*\R*").unwrap();
let string = "adrian-strauch@t-online.de:12xxxxxx | 5
svenschalke@t-online.de:kikerxxx | 33
dennis.meinhardt@t-online.de:vxxxxxx | 169
Fabibau@t-online.de:rofxxxx | 134
anders.gerd@t-online.de:townxxx | 1
anders.gerd@t-online.de:townxxx | test";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}