import re
regex = re.compile(r"^[a-zA-Z]{2}[0-9]{2}\s?[a-zA-Z0-9]{4}\s?[0-9]{4}\s?[0-9]{3}([a-zA-Z0-9]\s?[a-zA-Z0-9]{0,4}\s?[a-zA-Z0-9]{0,4}\s?[a-zA-Z0-9]{0,4}\s?[a-zA-Z0-9]{0,3})?$", flags=re.MULTILINE)
test_str = ("DE89 3704 0044 0532 0130 00\n"
"AT61 1904 3002 3457 3201\n"
"FR14 2004 1010 0505 0001 3\n"
"DE89370400440532013000\n"
"AT611904300234573201\n"
"FR1420041010050500013\n"
"DE89 370400440532013000\n"
"A T611904300234573201\n"
"FR1420 041010050500013")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")