re = /^[a-zA-Z]{2}[0-9]{2}\s?[a-zA-Z0-9]{4}\s?[0-9]{4}\s?[0-9]{3}([a-zA-Z0-9]\s?[a-zA-Z0-9]{0,4}\s?[a-zA-Z0-9]{0,4}\s?[a-zA-Z0-9]{0,4}\s?[a-zA-Z0-9]{0,3})?$/m
str = 'DE89 3704 0044 0532 0130 00
AT61 1904 3002 3457 3201
FR14 2004 1010 0505 0001 3
DE89370400440532013000
AT611904300234573201
FR1420041010050500013
DE89 370400440532013000
A T611904300234573201
FR1420 041010050500013'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end