re = /^(?>.*?(foo|bar|baz)){2}.*(*SKIP)(*F)|(?1)/im
str = 'Foo bar, Cambaz!
My bar, good!
My friend, Cambaz!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end