package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\?|&).*=`)
var str = `https://yandex.fr/search/?text=hello+world&lr=142&clid=1882610`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}