$re = '/(\?|&).*=/m';
$str = 'https://yandex.fr/search/?text=hello+world&lr=142&clid=1882610';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);