re = /(\?|&).*=/m
str = 'https://yandex.fr/search/?text=hello+world&lr=142&clid=1882610'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end