import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\{\\[]{1}([,:\\{\\}\\[\\]0-9.\\-+Eaeflnr-u \\n\\r\\t]+|\".*?\")+[\\}\\]]{1}";
final String string = "{\"a\":false, \"b\":true,\"c\":100,\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}