$re = '/[{\[]{1}([,:{}\[\]0-9.\-+Eaeflnr-u \n\r\t]+|".*?")+[}\]]{1}/';
$str = '{"a":false, "b":true,"c":100,"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);