re = /[{\[]{1}([,:{}\[\]0-9.\-+Eaeflnr-u \n\r\t]+|".*?")+[}\]]{1}/
str = '{"a":false, "b":true,"c":100,"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end