#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*[[:space:]]GRAVE:.*)"
Local $sString = "INFORMAZIONI: Parsing jar:file:/workarea/apache-tomcat/apache-tomcat-7.0.47_GA/webapps/GestioneAutorizzazioni/WEB-INF/lib/zkex-6.5.6.jar!/metainfo/zk/zk.xml" & @CRLF & _
"lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.sys.ConfigParser parse:269" & @CRLF & _
"INFORMAZIONI: Parsing jar:file:/workarea/apache-tomcat/apache-tomcat-7.0.47_GA/webapps/GestioneAutorizzazioni/WEB-INF/lib/zkmax-6.5.6.jar!/metainfo/zk/zk.xml" & @CRLF & _
"lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.sys.ConfigParser parse:269" & @CRLF & _
"INFORMAZIONI: Parsing jndi:/localhost/GestioneAutorizzazioni/WEB-INF/zk.xml" & @CRLF & _
"lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.http.WebManager <init>:172" & @CRLF & _
"INFORMAZIONI: Parsing file:///workarea/apache-tomcat/tomcatGA/confapps/GestioneAutorizzazioni/zk-production.xml" & @CRLF & _
"lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.http.WebManager <init>:179" & @CRLF & _
"GRAVE: File not found: file:///workarea/apache-tomcat/tomcatGA/confapps/GestioneAutorizzazioni/zk-production.xml" & @CRLF & _
"lug 26, 2022 10:30:26 PM org.zkoss.zk.ui.metainfo.DefinitionLoaders parseLang:410" & @CRLF & _
"AVVERTENZA: Component jasperreport ignored. Reason: unable to load org.zkoss.zkex.zul.Jasperreport due to java.lang.NoClassDefFoundError: net/sf/jasperreports/engine/JRDataSource" & @CRLF & _
"" & @CRLF & _
"Configuring Spring Security Core ..." & @CRLF & _
"... finished configuring Spring Security Core" & @CRLF & _
"" & @CRLF & _
"amministrazione-database: doWithSpring" & @CRLF & _
"anagrafe-soggetti: doWithSpring" & @CRLF & _
"struttura-organizzativa: doWithSpring" & @CRLF & _
"AmministrazioneDatabaseBootStrap: validate" & @CRLF & _
"lug 26, 2022 10:30:56 PM org.apache.catalina.startup.HostConfig deployWAR" & @CRLF & _
"INFORMAZIONI: Deploying web application archive /workarea/apache-tomcat/apache-tomcat-7.0.47_GA/webapps/probe.war" & @CRLF & _
"lug 26, 2022 10:30:58 PM org.apache.catalina.startup.HostConfig deployWAR" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")