import re
regex = re.compile(r"(.*[[:space:]]GRAVE:.*)", flags=re.MULTILINE)
test_str = ("INFORMAZIONI: Parsing jar:file:/workarea/apache-tomcat/apache-tomcat-7.0.47_GA/webapps/GestioneAutorizzazioni/WEB-INF/lib/zkex-6.5.6.jar!/metainfo/zk/zk.xml\n"
"lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.sys.ConfigParser parse:269\n"
"INFORMAZIONI: Parsing jar:file:/workarea/apache-tomcat/apache-tomcat-7.0.47_GA/webapps/GestioneAutorizzazioni/WEB-INF/lib/zkmax-6.5.6.jar!/metainfo/zk/zk.xml\n"
"lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.sys.ConfigParser parse:269\n"
"INFORMAZIONI: Parsing jndi:/localhost/GestioneAutorizzazioni/WEB-INF/zk.xml\n"
"lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.http.WebManager <init>:172\n"
"INFORMAZIONI: Parsing file:///workarea/apache-tomcat/tomcatGA/confapps/GestioneAutorizzazioni/zk-production.xml\n"
"lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.http.WebManager <init>:179\n"
"GRAVE: File not found: file:///workarea/apache-tomcat/tomcatGA/confapps/GestioneAutorizzazioni/zk-production.xml\n"
"lug 26, 2022 10:30:26 PM org.zkoss.zk.ui.metainfo.DefinitionLoaders parseLang:410\n"
"AVVERTENZA: Component jasperreport ignored. Reason: unable to load org.zkoss.zkex.zul.Jasperreport due to java.lang.NoClassDefFoundError: net/sf/jasperreports/engine/JRDataSource\n\n"
"Configuring Spring Security Core ...\n"
"... finished configuring Spring Security Core\n\n"
"amministrazione-database: doWithSpring\n"
"anagrafe-soggetti: doWithSpring\n"
"struttura-organizzativa: doWithSpring\n"
"AmministrazioneDatabaseBootStrap: validate\n"
"lug 26, 2022 10:30:56 PM org.apache.catalina.startup.HostConfig deployWAR\n"
"INFORMAZIONI: Deploying web application archive /workarea/apache-tomcat/apache-tomcat-7.0.47_GA/webapps/probe.war\n"
"lug 26, 2022 10:30:58 PM org.apache.catalina.startup.HostConfig deployWAR\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")