package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\d\n]*\d[^\d\n]*$`)
var str = `no digits in here
only 1 digit in here
more than 1 (ie 2) digits in here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}