re = /^[^\d\n]*\d[^\d\n]*$/m
str = 'no digits in here
only 1 digit in here
more than 1 (ie 2) digits in here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end