$re = '/^[^\d\n]*\d[^\d\n]*$/m';
$str = 'no digits in here
only 1 digit in here
more than 1 (ie 2) digits in here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);