#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?P<ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\s" & @CRLF & _
"(?P<name>\w+)\s" & @CRLF & _
"(?P<proto>\w+)\s" & @CRLF & _
"(?P<http_status_code>\d+)"
Local $sString = "172.16.1.1 bob tcp 200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")