re = /(?P<ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\s
(?P<name>\w+)\s
(?P<proto>\w+)\s
(?P<http_status_code>\d+)/mx
str = '172.16.1.1 bob tcp 200'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end