using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\n]+)\n?$";
string input = @"Via Strada di Pontenuovo, 42
Santa Marinella (Rome)
Santa Marinella, Rome 00058
Italy
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}