re = /([^\n]+)\n?$/
str = 'Via Strada di Pontenuovo, 42
Santa Marinella (Rome)
Santa Marinella, Rome 00058
Italy
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end