package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\n]+)\n?$`)
var str = `Via Strada di Pontenuovo, 42
Santa Marinella (Rome)
Santa Marinella, Rome 00058
Italy
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}