using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^test$([\S\s]*?)^a$";
string input = @"test
q3wers12893.,,.,adf
qwertre
asdfadf6785678..,.578
a
test
z5678567865...ertdfg
zrdf56786578g
a
test
rtert<ydfasdf---ert
werwer123424524
awtgwet241234
1124512326
a
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}