$re = '/^test$([\S\s]*?)^a$/m';
$str = 'test
q3wers12893.,,.,adf
qwertre
asdfadf6785678..,.578
a
test
z5678567865...ertdfg
zrdf56786578g
a
test
rtert<ydfasdf---ert
werwer123424524
awtgwet241234
1124512326
a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);