import Foundation
let pattern = #"^test$([\S\s]*?)^a$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test
q3wers12893.,,.,adf
qwertre
asdfadf6785678..,.578
a
test
z5678567865...ertdfg
zrdf56786578g
a
test
rtert<ydfasdf---ert
werwer123424524
awtgwet241234
1124512326
a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)