package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(?<key>\w+)"=(?<value>({.*?})|"?[^,]*"?)`)
var str = `"Key1"=123,"Key2"="abc","key3"={"subkey1"=12,"subkey2"="cd"},"key31"={"subkey1"=12,"subkey2"="cd"},"key4"=456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}