// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"(?<key>\w+)"=(?<value>({.*?})|"?[^,]*"?)"#).unwrap();
let string = "\"Key1\"=123,\"Key2\"=\"abc\",\"key3\"={\"subkey1\"=12,\"subkey2\"=\"cd\"},\"key31\"={\"subkey1\"=12,\"subkey2\"=\"cd\"},\"key4\"=456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}