re = /"(?<key>\w+)"=(?<value>({.*?})|"?[^,]*"?)/m
str = '"Key1"=123,"Key2"="abc","key3"={"subkey1"=12,"subkey2"="cd"},"key31"={"subkey1"=12,"subkey2"="cd"},"key4"=456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end