package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?P<age>[0-9]+) +)?(?:(?P<birthday>\d\d\d\d\-\d\d\-\d\d) +)?(?P<name>[\w ]+)`)
var str = `23 1990-10-10 Clark Kent
1990-10-10 Clark Kent
23 Clark Kent
Clark Kent`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}