const regex = new RegExp('(?:(?P<age>[0-9]+) +)?(?:(?P<birthday>\\d\\d\\d\\d\\-\\d\\d\\-\\d\\d) +)?(?P<name>[\\w ]+)', 'g')
const str = `23 1990-10-10 Clark Kent
1990-10-10 Clark Kent
23 Clark Kent
Clark Kent`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}