use strict;
my $str = '23 1990-10-10 Clark Kent
1990-10-10 Clark Kent
23 Clark Kent
Clark Kent';
my $regex = qr/(?:(?P<age>[0-9]+) +)?(?:(?P<birthday>\d\d\d\d\-\d\d\-\d\d) +)?(?P<name>[\w ]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}