$re = '/\b(?:LOT|LTS?) (\d+(?:-\d+)*)/m';
$str = 'LOT 8 BLK 32 MISSIONARY HEIGHTS
LTS 31-39 & PT 30, 15-22 LEWIS
LT 2 DEPOT SUB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);