// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:LOT|LTS?) (\d+(?:-\d+)*)").unwrap();
let string = "LOT 8 BLK 32 MISSIONARY HEIGHTS
LTS 31-39 & PT 30, 15-22 LEWIS
LT 2 DEPOT SUB";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}