re = /\b(?:LOT|LTS?) (\d+(?:-\d+)*)/m
str = 'LOT 8 BLK 32 MISSIONARY HEIGHTS
LTS 31-39 & PT 30, 15-22 LEWIS
LT 2 DEPOT SUB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end