$re = '/(\/verify\/.*)"/m';
$str = '<a href="mydomain/verify/fXxo4s_isP-mlm">Verify account</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);