re = /(\/verify\/.*)"/m
str = '<a href="mydomain/verify/fXxo4s_isP-mlm">Verify account</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end