$re = '#//\d+//#m';
$str = '"Someone submitted form //33//. That submission is located //36145//, unless deleted"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);