#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bA(?![^\d\n]*[A-Z]{2})[^\d\n]*(\d+)"
Local $sString = "A bcd 1 should match" & @CRLF & _
"Abcd1 should match" & @CRLF & _
"A bcd should not match because there is no number" & @CRLF & _
"A bCD 1 should not match because there is capital C between the A and the number " & @CRLF & _
"A bcd 1 B should match because `1` is before the B" & @CRLF & _
"" & @CRLF & _
"A test this is S 2 test B test 13 A again a test 4" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"A bcd 1 should match and capture 1" & @CRLF & _
"" & @CRLF & _
"Abcd1 should match and capture 1" & @CRLF & _
"" & @CRLF & _
"A bcd should not match because there is no number" & @CRLF & _
"" & @CRLF & _
"A BCd 1 should not match because there is a capital C between the A and the number" & @CRLF & _
"" & @CRLF & _
"A bcd 1 EF should match because 1 is before the EF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")