using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bA(?![^\d\n]*[A-Z]{2})[^\d\n]*(\d+)";
string input = @"A bcd 1 should match
Abcd1 should match
A bcd should not match because there is no number
A bCD 1 should not match because there is capital C between the A and the number
A bcd 1 B should match because `1` is before the B
A test this is S 2 test B test 13 A again a test 4
A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd should not match because there is no number
A BCd 1 should not match because there is a capital C between the A and the number
A bcd 1 EF should match because 1 is before the EF";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}