import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bA(?![^\\d\\n]*[A-Z]{2})[^\\d\\n]*(\\d+)";
final String string = "A bcd 1 should match\n"
+ "Abcd1 should match\n"
+ "A bcd should not match because there is no number\n"
+ "A bCD 1 should not match because there is capital C between the A and the number \n"
+ "A bcd 1 B should match because `1` is before the B\n\n"
+ "A test this is S 2 test B test 13 A again a test 4\n\n\n"
+ "A bcd 1 should match and capture 1\n\n"
+ "Abcd1 should match and capture 1\n\n"
+ "A bcd should not match because there is no number\n\n"
+ "A BCd 1 should not match because there is a capital C between the A and the number\n\n"
+ "A bcd 1 EF should match because 1 is before the EF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}