using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div\s+class=""preview item""[^>]*>\s*<img\s+[\s\S]*?src=\s?"".*?([^\/]+?)""";
string input = @"<div class=""preview item""><img alt=""
sizes=""(max-width: 440px) 320px""
src= ""https://m.testlink.com/test/zx320y230c_4130512.jpg""
srcset= ""https://m.testlink.com/test/zx320y230c_4130512.jpg 320w, https://m.testlink.com/test/zx640y460c_4130512.jpg 640w""></div>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}