# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div\s+class=\"preview item\"[^>]*>\s*<img\s+[\s\S]*?src=\s?\".*?([^\/]+?)\""
test_str = ("<div class=\"preview item\"><img alt=\"\"\n"
"sizes=\"(max-width: 440px) 320px\"\n"
"src= \"https://m.testlink.com/test/zx320y230c_4130512.jpg\"\n"
"srcset= \"https://m.testlink.com/test/zx320y230c_4130512.jpg 320w, https://m.testlink.com/test/zx640y460c_4130512.jpg 640w\"></div>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.