import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\s+class=\"preview item\"[^>]*>\\s*<img\\s+[\\s\\S]*?src=\\s?\".*?([^\\/]+?)\"";
final String string = "<div class=\"preview item\"><img alt=\"\"\n"
+ "sizes=\"(max-width: 440px) 320px\"\n"
+ "src= \"https://m.testlink.com/test/zx320y230c_4130512.jpg\"\n"
+ "srcset= \"https://m.testlink.com/test/zx320y230c_4130512.jpg 320w, https://m.testlink.com/test/zx640y460c_4130512.jpg 640w\"></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}