#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*SFR$"
Local $sString = "1468 SFR-PHOTO_000-€" & @CRLF & _
"CAP- 1235 SFR1-" & @CRLF & _
"C-Z01434-SFR- PHOTO 000-" & @CRLF & _
"C-Z01468-SFR" & @CRLF & _
"SN- 1468 --SFR•+-CE•-•Request-for-approval" & @CRLF & _
"PAC-X0123 SFR-" & @CRLF & _
"B-00123•- Invoice for ABC" & @CRLF & _
"C-925303-SFR-" & @CRLF & _
"C-L25254-SFR" & @CRLF & _
"C-LP1122 SFR-" & @CRLF & _
"A-123456 SFR" & @CRLF & _
"A-789654 SFR" & @CRLF & _
"A-Q12345-SFR" & @CRLF & _
"DDD-BN4455_SFR" & @CRLF & _
"WWW 78955_SFR" & @CRLF & _
"V 963852-SFR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")