import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*SFR$";
final String string = "1468 SFR-PHOTO_000-€\n"
+ "CAP- 1235 SFR1-\n"
+ "C-Z01434-SFR- PHOTO 000-\n"
+ "C-Z01468-SFR\n"
+ "SN- 1468 --SFR•+-CE•-•Request-for-approval\n"
+ "PAC-X0123 SFR-\n"
+ "B-00123•- Invoice for ABC\n"
+ "C-925303-SFR-\n"
+ "C-L25254-SFR\n"
+ "C-LP1122 SFR-\n"
+ "A-123456 SFR\n"
+ "A-789654 SFR\n"
+ "A-Q12345-SFR\n"
+ "DDD-BN4455_SFR\n"
+ "WWW 78955_SFR\n"
+ "V 963852-SFR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}