$re = '/.*SFR$/m';
$str = '1468 SFR-PHOTO_000-€
CAP- 1235 SFR1-
C-Z01434-SFR- PHOTO 000-
C-Z01468-SFR
SN- 1468 --SFR•+-CE•-•Request-for-approval
PAC-X0123 SFR-
B-00123•- Invoice for ABC
C-925303-SFR-
C-L25254-SFR
C-LP1122 SFR-
A-123456 SFR
A-789654 SFR
A-Q12345-SFR
DDD-BN4455_SFR
WWW 78955_SFR
V 963852-SFR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);