using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([ \t]*)(@\w+(\.\w+)*)([ \t]*)";
string input = @"@annotation
@annotation value
@annotation.long.namespace
@annotation.long.namespace value
@annotation.long.namespace
@annotation.long.namespace value";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}